Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5
tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are:
Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).
Input
A single line with two space-separated integers: N and K.
Output
A single line with a single integer that is the number of unique ways FJ can spend his money.
Sample Input
5 3
Sample Output
5
1个DP题 不过由于数太大了。。。所以我选用的java...
其中dp数组存贮组成当前数的个数
import java.math.*;
import java.util.*;
public class Main {
public static void main(String[] args) {
Scanner sca =new Scanner(System.in);
int k,n;
while(sca.hasNext())
{
n=sca.nextInt();
k=sca.nextInt();
BigInteger dp []=new BigInteger[1005];
for(int i=0;i<1005;i++)
dp[i]=BigInteger.ZERO;
dp[0]=BigInteger.ONE;
for(int i=1;i<=k;i++){
for(int j=0;j<=n;j++){
if(j>=i&&dp[j-i]!=BigInteger.ZERO){
dp[j]=dp[j].add(dp[j-i]);
}
}
}
System.out.println(dp[n]);
}
}
}